Jump to content
  • 0
Sign in to follow this  
slavikmc

Кодировка работает только на основной странице

Question

slavikmc    0

Есть хостинг от великого masterhost. Как понимаю там по умолчанию стоит кодировка windows-1251.

Загружаю сайт, сделанный в muse на сервер - какозябры.

Когда заливаю .htaccess c 

AddDefaultCharset UTF-8

или:

<FilesMatch ".(htm|html|css|js)$"> ForceType 'text/html; charset=UTF-8'  </FilesMatch>

или:

<FilesMatch ".(js|php)$"> AddDefaultCharset UTF-8 </FilesMatch>

или:

AddCharset UTF-8 .php

или даже так:

AddType 'text/html; charset=UTF-8' html
 
На основной странице все становится ок, но на других и даже в /index.html остаются какозябры.
 
Как через .htaccess сделать чтобы на всех страницах была правильная кодировка?

Share this post


Link to post

2 answers to this question

Recommended Posts

  • 0
slavikmc    0

Спасибо, решил)

в htacces

Options -Indexes 
RewriteEngine On
<IfModule mod_charset.c>
CharsetDisable On
</IfModule>
php_value default_charset utf-8
AddDefaultCharset UTF-8

Share this post


Link to post

Новая статья

Как бесплатно получить специализированный хостинг для Adobe Muse сайта. Читайте новую инструкцию по этой ссылке.
  • 0

Спасибо, решил)

в htacces

Options -Indexes 

RewriteEngine On

<IfModule mod_charset.c>

CharsetDisable On

</IfModule>

php_value default_charset utf-8

AddDefaultCharset UTF-8

Должно хватить и AddDefaultCharset UTF-8 - это жесткая команда для сервера, чтобы он выдавал браузеру только в UTF-8

Скорее всего, вы просматривали все страницы до настройки и страницы "закэшировались". С таким сталкивался не однократно - достаточно очистить кеш (после применения AddDefaultCharset UTF-8) и все стает нормально.

Попробуйте (для интереса) вновь все удалить и оставить только строчку AddDefaultCharset UTF-8

Share this post


Link to post
Sign in to follow this  

×
×
  • Create New...