Jump to content
  • 0
Sign in to follow this  
Павел Вайт

баги при загрузке сайта

Question

Привет! Мне нужна ваша помощь или совет :unsure:
сайт CHUDOPORTRET.RU

1. При загрузке сайта, мы слышим музыку из видео, которое присутствует на сайте, но отложено для показа. Оно должно проигрываться после нажатия на кнопку Play соответственно. Но когда страница грузится, мы УЖЕ СЛЫШИМ кусок аудио из него. Это сильно напрягает тех, кто заходит на сайт, они вскакивают не ожидая звуков. Вопрос- как избавится от бага

2. Если вы закроете видео, которое автоматически проигрывается на сайте. появится 6 превьюшек, которые можно включить.
Вопрос- Можно ли отложить их загрузку до момента, пока не нажали кнопку Play на соответствующей превью.
Как вообще отключить загрузку видео до мемента, пока оно действительно понадобится. :angry:

ЧТОБЫ ОНИ НЕ ГРУЗИЛИ САЙТ ПО НАПРАСНУ . Сайт из-за этих 4х видео грузится на 6 сек дольше обычного. 
Прошу совет.
 

Share this post


Link to post

3 answers to this question

Recommended Posts

  • 0

1) При загрузке сайта мы слышим музыку из видео которое уже запускается в лайтбоксе, пока работает прелодер, а не кусок звука незапущенного видео. То есть, всё работает так как вы настроили - видимо стоит галка автолайтбокс и автоплей в видео. Видимо у вас маленький монитор и вы просто этого не видите.

Здесь ссылка, но видят ее только участники клуба. Вступите в клуб по этой ссылке.

2) У вас кроме видео используется композиция, в которую эти видео вставлены, поэтому если вы хотите сохранить этот дизайн, то ваш вопрос в данном контексте не имеет смысла. Просто смиритесь. Или пересмотрите дизайн этого блока. Придется немного пописать код.

И, head вашего сайта содержит 614 строк кода, так что видео - это наименьшая проблема ;).

Здесь ссылка, но видят ее только участники клуба. Вступите в клуб по этой ссылке.

Share this post


Link to post

Новая статья

Как бесплатно получить специализированный хостинг для Adobe Muse сайта. Читайте новую инструкцию по этой ссылке.
  • 0

Спасибо за ответ. 
НО, не совсем так. 

Проблема именно в том, что звук ( пару сек) проигрывается из видео, которое на шапке сайта. А оно не "автоплэй." Сейчас это понять сложнее, тк я добавил еще 6 видео в другой блок, и да, оно автоплэй. 

Если проще- у меня естьт композиция, в ней видео которое автоплэй, но появление композиции по тригеру.
Заходим на сайт, и пока не нажмем на кнопку, видео не появится и следовательно проигрываться не будет. 

А на деле - пока сайт грузится, появляется музыка из видео. Потом когда сайт загрузился полностью, звук исчезает. и композиция спрятана как должна быть.. 

Демагогия конечно вышла, но все же. 

На счет 600строк. если я уберу блок с 6ти видео, сайт будет грузится менее секунды.

Share this post


Link to post
  • 0
8 часов назад, Павел Вайт сказал:

Если проще- у меня естьт композиция, в ней видео которое автоплэй, но появление композиции по тригеру.
Заходим на сайт, и пока не нажмем на кнопку, видео не появится и следовательно проигрываться не будет. 

Я не знаю, как и что у вас появляется. У меня это появляется именно так как я описал и не иначе. Никаких 2 секунд звука из шапки. Сразу запускается то видео со звуком, которое я показал на скриншоте ( еще во время пока прелодер страницы крутится). Браузер Firefox. На лицо конфликт скриптов, причем судя по всему, по разному отрабатывающий в разных браузерах.

Те 600 строк кода говорят о том, что на вашем сайте множество сторонних виджетов или кода. Судя по тому, как загружается страница  имеется значительное вмешательство в код сайта. Когда вы сталкиваетесь с проблемой - это первое что надо описывать, задавая вопрос, и от чего надо избавляться для решения проблемы. Удаляйте всё стороннее, действуя методом исключения, пока проблема не исчезнет.

Share this post


Link to post
Sign in to follow this  

×
×
  • Create New...