Перейти к содержимому
  • 0
miha_igor

Вместо сайта белый фон

miha_igor    0

Сайты скинуты на хостинг, все файлы на месте. 

Но сайты не работают, белый экран или фон.

При обращении к техподдержке хостинга - пишут:

Я вижу в консоли браузера, что некоторые js-скрипты стали недоступны, и есть ошибки выполнения: Uncaught TypeError: $(...).mask is not a function
404 not found:
(index):571 GET Здесь ссылка, но видят ее только участники клуба. Вступите в клуб по этой ссылке.
(index):573 GET Здесь ссылка, но видят ее только участники клуба. Вступите в клуб по этой ссылке.
(index):571 GET Здесь ссылка, но видят ее только участники клуба. Вступите в клуб по этой ссылке. 404 (Not Found)
(index):573 GET Здесь ссылка, но видят ее только участники клуба. Вступите в клуб по этой ссылке. 404 (Not Found)

В той же консоли браузера я вижу, что сам контент доставляется, но есть проблемы с его интерпретацией самим браузером.

И вот как понимать, что некоторые скрипты стали недоступны?!

Подскажите, пожалуйста, в какую сторону думать и что можно сделать?!

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Рекомендуемые сообщения

  • 0
1 минуту назад, miha_igor сказал:

Подскажите, пожалуйста, в какую сторону думать и что можно сделать?!

Я так понимаю, сайты сделаны на Adobe Muse 2015.2? Обратитесь к разработчикам виджетов (если вы их покупали конечно) за обновлением

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Новая статья

Как бесплатно получить специализированный хостинг для Adobe Muse сайта. Читайте новую инструкцию по этой ссылке.
  • 0

TypeError: $(...).mask is not a function

Проблема в виджете, либо у Вас виджет "Удобная форма", либо виджет "Маска ввода".

Вариант первый: Отказаться от виджета, пока не найдете обновленный виджет.

Вариант второй :

Открываем index.html текстовым редактором, ищем что-то вроде:

<script type="text/javascript">
    $(document).ready(function(){$('.maska > input').mask('+7 (999) 999-99-99',{placeholder:'X'});

Заменяем часть кода, а именно  $(document).ready(function(){, заменяем на  $(document).ready(function($){

Должно помочь

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
  • 0

Всем привет!

Имею подобную проблему.

Сайт сделан полностью в музе, руками ничего не правил, только у одного скрипта включил асинхронную загрузку, что повысило скорость загрузки сайта.

Проблема проявилась при подключении скриптов CallBack (Zadarma) и Онлайн Консультанта (Venyoo).

Если сайт загружать в браузере с очищенным кэшем и т.п. - то в 70-80% случаев загружается белый фон. Если понажимать F5 - то сайт загружается и в 90% случаев дальше работает нормально. Но, стоит очистить хистори - опять нихрена не работает.

В мобильной версии все еще хуже, там даже с кешем через раз работает.

Как только отключаешь скрипт Zadarma - становится все нормально.

Скрипт Онлайн Констультанта тоже влияет на белый фон, но в значительно меньшей степени.

В музе откровенно новичок, перелопатил уже много инфы, но не могу понять почему простой скрипт, который работает на куче других сайтов вызывает такой косяк.

Cайт: stroim-sip.ru

Буду благодарен советам и рекомендациям.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
  • 0

В фаерфокс сайт не открывается совсем. Ну и проблему вы сами установили. Что вы хотите еще узнать? Почему? Слишком много скриптов и конфликты между ними - видимо по этому. К тому же непорядок - метрика и аналистик установлены не правильно. Аналистик в хэде должна быть метрика в конце боди. Честно говоря не вижу смысла обе системы устанавливать.

В общем удалите всё стороннее пока проблема не уйдет.

32 минуты назад, Николай М сказал:

только у одного скрипта включил асинхронную загрузку

У Музы итак стоит асинхронная загрузка скриптов начиная с версии 2015.2. Так что что либо менять в ее родном коде не стоит.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
  • 0

Павел, спасибо за комментарий. Метрику и Аналитикс подправил.
Насколько мне известно - аналитикс дает больше информации по сайту, чем метрика, но с ним ни разу не работал, поэтому и поставил его чтобы разобраться.

Скрипт в котором я включил асинхронную загрузку:

<script type="text/javascript">
   document.write('\x3Cscript async src="' + (document.location.protocol == 'https:' ? 'https:' : 'http:') + '//webfonts.creativecloud.com/open-sans:n7,n4,i4,n8,n6:default.js" type="text/javascript">\x3C/script>');
</script>

По сути - у меня сайт сделанный только на музе, ничего дополнительного кроме метрики и аналитики я не подключал - в этом варианте все работает.
 

По поводу FireFox - да, он оказался самый привередливый, в нем я работу ОнлайнКонсультанта не тестировал. Сейчас проверил - убрал метрику, аналитику, Zadarma - оставил только консультанта - тоже не работает. Убрал консультанта - заработало.

Но что же делать в моем случае, очень нужна кнопка CallBack и Онлайн Консультант...
Поскольку это ленд, на который будет литься реклама из директа и, соответственно, надо повышать его конверсию.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
  • 0
8 часов назад, Николай М сказал:

Но что же делать в моем случае, очень нужна кнопка CallBack и Онлайн Консультант...

Подберите другого консультанта  - живосайт например. У тех скриптов которые вы устанавливаете есть подключаемые библиотеки. Возможно они конфликтуют с музовской. Всегда, если скрипт не работает ищите аналог. И правильно устанавливайте.

8 часов назад, Николай М сказал:

По поводу FireFox

Я потом и в хроме посмотрел - тоже не работало.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
  • 0

Павел, сегодня перетряхнул весь сайт.

Удалил все точки остановки, и далее постепенно удалял весь контент, удалил 95% и только в самом конце ошибка исчезла.

В итоге сделал 2 страницы Здесь ссылка, но видят ее только участники клуба. Вступите в клуб по этой ссылке. и Здесь ссылка, но видят ее только участники клуба. Вступите в клуб по этой ссылке. - контент почти одинаковый, а результат загрузки разный.

Разбор полетов показал, что на ошибку влияет index.css.

Например, есть такие элементы:

.js body {
	visibility:hidden;
}
.js body.initialized {
	visibility:visible;
}

Если в отладчике FF ее выкинуть первый - страничка (маленькая) загружается.

Если проверять на "большом" сайте - контент загружается, но без картинок и кнопок...

Если честно, мне не очень понятно за что отвечают эти строчки и из-за чего боди то скрывается, то нет. 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
  • 0
11 час назад, Николай М сказал:

азбор полетов показал, что на ошибку влияет index.css.

Например, есть такие элементы:


.js body {
	visibility:hidden;
}
.js body.initialized {
	visibility:visible;
}

Если в отладчике FF ее выкинуть первый - страничка (маленькая) загружается.

Если проверять на "большом" сайте - контент загружается, но без картинок и кнопок...

Если честно, мне не очень понятно за что отвечают эти строчки и из-за чего боди то скрывается, то нет. 

Ну что вы ерундой страдаете то? Хотите код править - делайте сайт в дримвивере или в блокноте пишите.

Если вы делаете сайт в музе используя ее штатные средства, то всё будет работать. Уже ш вроде определились что мешает, однако упорно продолжаете это устанавливать. Причем устанавливать не правильно.

Здесь ссылка, но видят ее только участники клуба. Вступите в клуб по этой ссылке.

Аналистик аж две копии и обе неправильно установлены.

Здесь ссылка, но видят ее только участники клуба. Вступите в клуб по этой ссылке.

Честно говоря для меня странно - если вы не знаете где у сайта head, зачем вы вообще пытаетесь найти какие то ошибки в коде?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
  • 0

Павел, где HEAD - я знаю. А 2 аналитики не на месте - последствия вчерашних исследований. Утром все было на своих местах, видимо что-то не там скопировал в конце дня т.к. билд был дома.

Если делать сайт только в музе - да, он работает, но так или иначе есть потребность в установке сторонних сервисов которые везде прекрасно работают, кроме как в музе.

Причем сайт-то загружается, но боди скрывается по какой-то причине. Вот, собственно, эту причину я и хочу найти. Не думаю, что MUSE не способен подключить к себе 2 сторонние кнопки.

По поводу аналитики, да, может она и установлена на данный момент неправильно, но она никак не влияет на проблему, поскольку при ее удалении ничего не меняется.

Проблема белого экрана так или иначе встречается в рунете, какое-то решение должно же быть. А вариант не ставить необходимые сторонние сервисы - не самый лучший, хоть и решает проблему.

В любом случае, спасибо за помощь и прошу прощения, что не уследил за неправильной аналитикой. Мой косяк:)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
  • 0
33 минуты назад, Николай М сказал:

Проблема белого экрана так или иначе встречается в рунете, какое-то решение должно же быть.

Именно это и является решением:

33 минуты назад, Николай М сказал:

А вариант не ставить необходимые сторонние сервисы - не самый лучший, хоть и решает проблему.

Не вижу никакой сложности использовать другие скрипты.

Загрузите сюда тот файл.muse в котором белый экран - один из ваших экспериментальных.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
  • 0

Павел, во вложении проект с маленькой страничкой, которая в FF отображается но не всегда. Т.е. если очистить кэш и зайти на сайт, либо понажимать F5 - загружается белый экран.
Если зайти с мобильного Хрома - то тоже белый экран после очистки кэша.
Ссылка на  страницу Здесь ссылка, но видят ее только участники клуба. Вступите в клуб по этой ссылке.

P.S. Проект без скриптов, их прописывал после билда вручную.

Здесь ссылка, но видят ее только участники клуба. Вступите в клуб по этой ссылке.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
  • 0
59 минут назад, Николай М сказал:

Проект без скриптов

Так а зачем же мне без скриптов - работает прекрасно, воспроизвести проблему невозможно. В нем и не будет этой проблемы. Нужно со скриптами.

59 минут назад, Николай М сказал:

их прописывал после билда вручную

А смысл? Если только вам нравится преодолевать трудности :lol:. Всё надо вставлять внутри музы.

...

Никогда не вставляйте в Музу изображения, которые планируется использовать на сайте. Только через "поместить".

5fb57d613b.png

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
  • 0
Цитата

Так а зачем же мне без скриптов... Если только вам нравится преодолевать трудности...

Ну я же говорю - с музой недавно) Только сейчас нашел волшебный плагин для вставки кода перед закрытием body:)

Цитата

Никогда не вставляйте в Музу изображения

Они пришли из некого шаблона, найденного в инете - сразу понял что это плохо, но банальный вопрос - как удалить элементы с замочком?

Вставил в проект скрипты, в FF стало работать хуже:)
Ссылка та же: Здесь ссылка, но видят ее только участники клуба. Вступите в клуб по этой ссылке.

Здесь ссылка, но видят ее только участники клуба. Вступите в клуб по этой ссылке.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
  • 0

Коллбэк работает нормально. Виновник проблем только онлайн консультант - и это частое явление среди них, не только по отношению к Музе. Так что расставьте приоритеты - что для вас главнее - Муза или какой то там скрипт консультанта. Установите живосайт и проблем не будет.

8 часов назад, Николай М сказал:

но банальный вопрос - как удалить элементы с замочком

Это не с замочком, это изображение-замочек :). Просто найдите его на сайте и удалите. Если оно не расположено на сайте, удалить именно из панели ресурсов не получится.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
  • 0

На маленьком сайте да, не работает только консультант, на большом - не работает и кнопка.

Значит будем искать другого консультанта... Фишка в том, что это чат-бот, адекватных аналогов пока не нашел ...

По замочку - все понятно, на сайте его нет:)

Спасибо за аомощь!;)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

×