Jump to content
  • 0
Sign in to follow this  
dimitrian777

Интеграция анимации edge animate.

Question

Прошу помощи. Такая ситуация. Нужно разместить на сайте html5 баннеры, сделанные в adobe edge. Делаю так... Команда "Поместить" и выбираю OAM файл. Баннер помещается и имеет оригинальный вид, но в режиме "Просмотр" вместо градиента серый фон, вместо овалов, прямоугольники и качество картинок в баннере заметно снижено(контрастность, рваные края изображений). При просмотре в браузере баннер вообще не отображается. Сайт локальный так, что ссылку дать не могу. Посоветуйте в каком направлении копать?

Share this post


Link to post

Recommended Posts

Новая статья

Как бесплатно получить специализированный хостинг для Adobe Muse сайта. Читайте новую инструкцию по этой ссылке.
  • 0

Прошу помощи. Такая ситуация. Нужно разместить на сайте html5 баннеры, сделанные в adobe edge. Делаю так... Команда "Поместить" и выбираю OAM файл. Баннер помещается и имеет оригинальный вид, но в режиме "Просмотр" вместо градиента серый фон, вместо овалов, прямоугольники и качество картинок в баннере заметно снижено(контрастность, рваные края изображений). При просмотре в браузере баннер вообще не отображается. Сайт локальный так, что ссылку дать не могу. Посоветуйте в каком направлении копать?

​В режиме просмотра анимация отображается не корректно. ее надо смотреть только в браузере. Перед вставкой анимации необходимо поместить файл oam в ту же папку в которой находится файл мьюз.
Скажите, а после того как вы нажали просмотр в браузере, вы пробовали перезагружать пустую страницу? Бывает анимация воспроизводится после этого, причем в мозиле наблюдается такое, а в хроме воспроизводится сразу. Почитал форумы адобе на эту тему - пишут что требуются танцы с бубнами в файле htaccess. Даже разбираться не стал. Кросссбраузерность хромает. Именно поэтим причинам An не может до сих пор завоевать рынок, как это сделала мьюз
В целом в ходе своих экспериментов с этими двумя программами, пришел к выводу что использовать эйдж анимейт для вставки в мьюз не целесообразно  - возникает много багов по непонятным причинам. Чуть лучше обстоит дело при вставке в Дримвивер, но если используется видео - это ппц полнейший. Кросс браузерность у An хромает.
На данный момент эта программа довольно сыра и лично мое мнение - красивая игрушка, но не для серьёзных проектов, пока разработчики над ней хорошо не поработают.
Так что на данный момент самым надежным способом делать HTML5 анимацию, пока остаются блокнот и знания JS и html

Share this post


Link to post
  • 0

Скажите пожалуйста вот у меня код банера (<a target="_blank" href="http://redsurf.ru/?r=203796"><img src="http://redsurf.ru/bn/3.gif" border="0" /></a>) который нужно разместить через Adobe Muse.Как правильно мне это сделать.

Share this post


Link to post
  • 0
4 часа назад, Прищепа Виктор сказал:

Скажите пожалуйста вот у меня код банера (<a target="_blank" href="http://redsurf.ru/?r=203796"><img src="http://redsurf.ru/bn/3.gif" border="0" /></a>) который нужно разместить через Adobe Muse.Как правильно мне это сделать.

ctrl+C,  ctrl+V на  странице

Share this post


Link to post
  • 0
Bovsky    1

тоже вопрос по баннеру HTML5

Делаю его в ГуглВебДизайнер, получаю zip. В нём index.html и картинки png. Вставляю в Мьюз, чтобы воспроизводилось, как блок HTML, но не знаю куда залить картинки. Как быть?

Share this post


Link to post
  • 0
39 минут назад, Bovsky сказал:

но не знаю куда залить картинки. Как быть?

Картинки залить через меню Файл / Добавить файлы для передачи. В HTML коде надо поменять пути к этим картинкам с того который есть на assets/ваша_картинка.jpg

Share this post


Link to post
  • 0
Bovsky    1

сделал так, всё хорошо показывается. Но! когда вставляю на страницу второй такой же баннер - ни один из них не показывается. Можт во время вставки HTML нужно что-то подправить? можт имена где-то совпадают и конфликтуют? можт подключается одна и та же библиотека и браузер не знает какую из них запускать?

Баннер приаттачил, второй баннер такой же, только картинка другая и текст отличается, но картинки первого и второго - в разных папках храню на хостинге.

Помогите решить проблему

Здесь ссылка, но видят ее только участники клуба. Вступите в клуб по этой ссылке.

Share this post


Link to post
  • 0
19 минут назад, Bovsky сказал:

Можт во время вставки HTML нужно что-то подправить? можт имена где-то совпадают и конфликтуют?

Именно это и происходит скорее всего. Вам надо перелопатить все файлы и везде заменить ID объектов на уникальные. Имело смысл приложить оба баннера, для того что бы сравнить. Один баннер ни о чем не говорит. Но скорее всего проблема менно в одинаковых айдишниках.

Share this post


Link to post
  • 0
Bovsky    1

вот второй

Здесь ссылка, но видят ее только участники клуба. Вступите в клуб по этой ссылке.

Share this post


Link to post
  • 0
5 минут назад, Bovsky сказал:

вот второй

Здесь ссылка, но видят ее только участники клуба. Вступите в клуб по этой ссылке.

Я же вам уже ответил. В данный момент мне это уже не надо. Откройте индексные файлы и сравните idшники. Наверняка найдете одинаковые. И имена файлов проверьте - не должно быть одинаковых. И всё это надо изменить в коде, во всех местах где упоминается.

Share this post


Link to post
  • 0
Bovsky    1

Сравнил построчно, там всё одинаковое: скрипты, классы, стили, CSS... 

совпадающие ID заменил в одном из файлов, но результат прежний, а менять остальное для меня - тёмный лес...

Может как-то через I-frame их показать получится? Видео же показывается так...

Share this post


Link to post
  • 0
11 час назад, Bovsky сказал:

Может как-то через I-frame их показать получится?

В том числе и поэтому гугл веб дизайнером никто не пользуется. Если бы вы сделали баннеры в Animate CC, там есть специальный формат экспорта OAM в который вшит iframe.

Другое дело, что iframe тоже не очень хорошо и удобно, но это самый простой и очевидный выход. Я подумал, что как раз от iframe вы хотите уйти, поэтому не стал рекомендовать вам это.  Можете сделать через iframe конечно. В чем проблема?

Share this post


Link to post
  • 0
Bovsky    1

Пробовал через iframe - во времени загрузки проблема. Баннер не показывается, пока не загрузится. Т.е. пауза между показами нескольких баннеров в 3-4 секунды. Они в композиции, по 7 сек. на показ. Первый идёт норм, второй с задержкой, во время которой пустое поле, а затем анимация обрывается не закончившись, и начинается показ первого баннера.

Попробую в AnimateCC переделать...

Share this post


Link to post
  • 0
Bovsky    1

Ну, с OAM задержка почти не видна. Белое поле на долю секунды смотрится как переход между баннерами. Костыль, конечно ))

Всё равно интересно, почему два GWD-баннера не работают вместе... Я пробовал переименовать все классы, стили, всё похожее (разве что только переменные в скриптах не трогал). Один и тот же итог. 

Share this post


Link to post
  • 0
17 минут назад, Bovsky сказал:

Ну, с OAM задержка почти не видна. Белое поле на долю секунды смотрится как переход между баннерами. Костыль, конечно ))

Всё равно интересно, почему два GWD-баннера не работают вместе... Я пробовал переименовать все классы, стили, всё похожее (разве что только переменные в скриптах не трогал). Один и тот же итог. 

В скриптах тоже надо переименовывать - там же задействованы эти классы и IDшники. Иначе как оно всё работало бы? Толку от того что вы их только в html коде переименовали нет никакого. ;)

Share this post


Link to post
Sign in to follow this  

×
×
  • Create New...